Высокие статистические технологии

Форум сайта семьи Орловых

Текущее время: Чт июн 29, 2017 5:15 am

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 4 ] 
Автор Сообщение
 Заголовок сообщения: в Excel изменяемый путь в формуле к ячейке
СообщениеДобавлено: Пт сен 22, 2006 12:18 pm 
Не в сети

Зарегистрирован: Пт сен 22, 2006 11:48 am
Сообщений: 2
У меня такая проблема:
- есть несколько файлов, которые готовят разные люди, я их все свожу
- в сводном файле есть формула Excel ВПР(искомое_значение;таблица ;номер_столбца ;интервальный_просмотр)
- в данной формуле стоит таблица находится в другой книге, т.е. путь к диапазону следующий: [Книга1.xls]Лист1!$A$4:$H$8
- мне необходимо этот путь заность в отдельную ячейку, т.е. в ячейке А1 записанно: [Книга1.xls]Лист1!
- а там, где результат, учитывать путь из ячейки А1, чтоб при изменении пути, и путь в формуле менялся

Заранее спасибо


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт сен 26, 2006 2:40 am 
Не в сети

Зарегистрирован: Пн дек 19, 2005 10:45 am
Сообщений: 19
A1=[Книга1.xls]Лист1!
B1=ВПР(ИСКОМОЕ_ЗНАЧЕНИЕ;ДВССЫЛ($A$1&"$A$4:$H$8");НОМЕР_СТОЛБЦА;0)

Только необходимо обязательно помнить, что рабочая книга, которая служит источником данных (в данном случае - Книга1.xls) обязательно должна быть открыта. В противном случае стандартная функция рабочего листа =ВПР() возвратит значение ошибки.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт сен 26, 2006 9:00 am 
Не в сети

Зарегистрирован: Пт сен 22, 2006 11:48 am
Сообщений: 2
pashulka писал(а):
A1=[Книга1.xls]Лист1!
B1=ВПР(ИСКОМОЕ_ЗНАЧЕНИЕ;ДВССЫЛ($A$1&"$A$4:$H$8");НОМЕР_СТОЛБЦА;0)

Только необходимо обязательно помнить, что рабочая книга, которая служит источником данных (в данном случае - Книга1.xls) обязательно должна быть открыта. В противном случае стандартная функция рабочего листа =ВПР() возвратит значение ошибки.


Огромное спасибо, все вышло, по описанию и непоймешь, что формулу можно так использовать :oops:


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: в Excel изменяемый путь в формуле к ячейке
СообщениеДобавлено: Сб янв 03, 2015 3:36 am 
Не в сети
Site Admin

Зарегистрирован: Пн сен 27, 2004 10:26 pm
Сообщений: 114
sajjad321, не очень понятно задание.
Вы желаете написать макрос, который при клике на ячейке С16 менял бы её значение на значение из ячейки С22?


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 4 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB